≡ Menu
Joe Colantonio – Selenium-UFT-QTP-SoapUI-ALM-LoadRunner & more

QTP 11 – Hotfixes for Oracle, WebDynpro, SAP, Powerbuilder, WSDL, WPF issues

QTP 11 – Hotfixes for Oracle, WebDynpro, SAP, Powerbuilder, WSDL, WPF issues post image

Latest QTP Hotfix Info:

Here are the latest QuickTest Professional issues that I can find hotfix information for.

Unlike patches — hotfixes cannot be downloaded from HP without first contacting them. So you will need to open a ticket with HP using their case manager website to request a hotfix.

  • WPFTreeview Issue:

    WPFTreeview unable to select item using index issue. QTP displays a ‘Run Error’ when passing an index value to select an item in a WpfTreeView control.

    Fix:

    Hotfix QTPNET_00113

  • SAP GUI 7 Issue:

    SAP GUI 7.10 “QTP has stopped working” error when running a testset from QC with a script that is trying to send keys to the SAPGuiWindow object. Also the error “Microsoft Visual C++ Runtime Library” might appear.

    Fix:

    Hotfix QTPSAP_00047

  • SAP Web Applications Issue:

    SAP Adding affects and lead to errors during run of existing scripts, created with Web Addin for SAP Web Applications. Caused if an action which was created with only the Web Add-in loaded is being run when other Add-ins are loaded some of the Web test objects may not be recognized. This is due to the fact that the additional Add-in identifies this DOM element as belonging to another test object.

    In these cases the action may fail to run due to not being able to identify the Web Add-in test object.

    Fix:

    Hotfix QTPWEB_00096 (Need to have QTPWEB_00090 installed first before installing QTPWEB_00096)

  • Oracle Issue:

    Spy fails to see Oracle objects under OracleTabbedRegions

    Fix:

    A Hotfix is available through HP Support (I was unable to find the hotfix name for this issue)

  • WebDynpro Issue:

    When recording against WebDynpro Script generation is very slow.

    Fix:

    The hotfix improves the performance of recording steps on SAP Web controls in situations when an operation on a Web page causes the page to be reloaded in the Web browser. (I was unable to find the hotfix name for this issue)

  • QTPNET_00114 Install Issue:

    Installing QTPNET_00114 causes QTP to enter an invalid state blocking other hotfixes from installing correctly. This is caused by having a conflict with two 64-bit related hotfixes – QTPNET_00114 and QTPWEB_00086.

    Fix:

    For the QTPNET hotfix to install correctly one of the following scenarios must be met:

    •QTP_00699 and QTPNET_00113 are both already installed, and QTPWEB_00086 is not installed on the machine.

    •QTP_00699, QTPNET_00113, QTPWEB_00086 and QTPWEB_00098 are all installed on the machine.

  • WSDL issue:

    Object repository contains blank properties for a specific WSDL file.

    Fix:

    QTP_00908 – Fix Blank Test Object’s Property Page in Object Repository

  • The QC Automatic Runner Issue:

    The QC Automatic Runner freezes when running flows from QC. After running for a long time it finishes with the status of the flow as “Failed”. This is caused by running a flow that takes a long time. There are some settings in the QTP Remote Agent that an help handle longer transactions.

    Fix:

    1. Update the mic.ini file:

    a. Open the \bin\mic.ini file in a text editor

    b. Find the [RemoteAgent] line and add the following line to the end of that section:

    HandleLongTrans=1

    2. Restart the computer

    3. Install hotfix QTP_00698 for QTP.

  • Data Table Parameters Issue

    Issues trying to modify data table parameters for external actions in certain tests. For certain tests, it is not possible to modify the data table parameters of the external actions. When opening the “Action Properties” dialog of an external action from the test flow, it is possible to select one of the following options from the external action tab:

    1. Use data stored with original action (read-only).

    2. Use a local, editable copy.

    This selection can be modified but once that the test is saved and re-opened, the original selection is present again overwriting the changes. The issue seems to be related to file “Resource.mtr” of the action called. Hotfix QTP_00891

  • Powerbuilder issue

    QTP hanging on line SelectCell in run mode over a Powerbuilder application.

    Fix:

    Hotfix QTPPB_00033

     

For an updated list of all patches available for QTP 11 check out the Patches section in my article: QTP 11 Support Matrix with Patch Updates


18 comments… add one

  • sophia

    Hi,

    I have a query, could you please help me out in solving this issue.

    The query is,

    I am working on an application which is developed using Powerbuilder 11.5. We are using QTP 11 to automate this application as part of testing.

    In our application, there is a scenario, where in, we have to click a “button” kind of object, which in turn displays a pbdatawindow and select the value from the table and click on “OK”.

    Now while recording this whole scenario, the clicking operation on the button object is not getting recorded. Due to this, what happens is when I try to playback the same scenario, QTP throws runtime error that it is not able to identify the button object.

    Kindly help me out in resolving this issue. Thanks.

    • Joe Colantonio

      sophia » Hi – When you spy on it what type of object does QTP say the button is?

      • sophia

        Hi Joe,

        Apologies for not responding to your emai…

        Anyways thanks a lot for taking up my query….

        Actually, when I spy on the button, QTP only identifies the pbwindow not the button.

        When I record the same scenario, QTP does not record the operation performed on the button, but it displays the pbdatawindow which gets popped up once the button is clicked and selecting of data in the pbdatawindow is also recorded.

        Joe, kindly help me out in this..

        Thanks

        Once again sorry…

  • Penny

    Hi,
    I have an issue for QTP webservice report, please help me to solve:
    I am working on webservice project. After the QTP Script running, the QTP report will popup, in Capture Data panle, the Request and Response are blank, it should be expected to display the request and reply xml info.

    • Joe Colantonio

      Penny » Hi Penny what happens if in the HP Run Results Viewer you click on View and select ‘Restore Layout’ – does that help? Sometimes the viewer get corrupted and restoring the layout helps.

      • the Request and Response are blank, it should be expected to display the request and reply xml info.
        ———————————
        it only happen in windows7 professional,But is Ok with XP and windows 7 Ultimate

  • Penny

    Sorry for late reply. I had a try, but still can’t display the request/response xml file.

  • Prasath

    Hi Joe
    I am facing ‘Catastrophic Failure’ error in QC 10 while running QTP11 scripts to automate SAP Gui 6.0 Application. As you said the SAP transaction takes long time to execute some times, QC thinks the connection between QTP & AUT is dead eventually it throws that failure error. I’ve launched a case with HP support too meanwhile I want to try the patch QTP_00698, can you tell me where will I find it?

    BTW your webpage is so useful..hats off..
    Thanks.

    • Joe Colantonio

      Prasath » Thanks Prasath – Unfortunately QTP_00698 is a hotfix not a patch — because of this you need to request it from HP Software Support Services in order to obtain the hotfix.

  • Hiro

    Hi Joe,

    I cannot find the QTPWEB_00096. Would you please put it in your download page please?
    And btw, your page is so so so helpful. Many thanks.

    Regards

    • Joe Colantonio

      Hiro » Thanks Hiro – because this is a hotfox HP does not allow it to be downloaded without contacting HP Support. Sorry you need to contact HP to get a hotfix.

  • Gayatri

    I am trying to automate the Webservice (WSDL). QTP was able to identify the WSDL but it is giving me the wrong xsi:type and wrong xmlns:q1 type for the Request details. The available Operations it is showing exactly correct as per the WSDL but if you select one Available option as Selected option the XML check point gets created. When i want to define the values in Edit XML structure the for the Attribute xsi:type the value is showing wrong value. How to solve this issue?

    • Gayatri » Hmm you stumped me on this one. Not sure why this is happening except I’m not surprised. QTP stinks at testing web services. One way to make sure its a QTP issue and not a web service issue is to also try the free version of SoapUI and see if you get the same behavior. If so you might want to contact HP – but I think their response would be to try HP Service Test instead,

  • Mark M.

    Hi Joe,

    I read with interest that there’s a solution available for the data table parameters issue. It’s very annoying that QTP keeps changing the saved settings. You mention Hotfix QTP_00891 is available to solve the issue, however, I can’t find the fix anywhere. Can you add a link to the issue or inform about a workaround?

    Thanks in advance & keep up the good work!

  • Axel Betancourt

    Hi

    I´m working with QTP 11.00 and i try to record a script in ADF application but the tool not recognize objetcs in that application. I try with java addin, web addin, oracle addin, oracle and java addin, oracle and web add in. But no addin recognizes objects

    Can you help me?

    • Anyone have any experience using QTP with ADF applications? If so please let us know how you resolved these types of issues.

  • Priya

    Hi Joe

    I am working on QTP 11 and IE8,
    SystemUtil.run command is opening 2 browsers.
    I did not face this issue in IE6.
    THe Record and Run Settings are Correct.
    Can you help

    Thanks

Leave a Comment

css.php