QTP 11 – Slow Object Repository Performance on Windows 7

PerfectoTopAd

Object Repository Slow

Are you trying to make changes to your QTP object repository, like renaming, deleting, pasting on a windows 7 machine and experience performance slower than a herd of turtles stampeding through peanut butter?

No worries – looks like this is a known issue.

What causes this QTP OR Behavior?

When editing object repositories in QuickTest Professional, QTP needs to go through the entire OR hierarchy to adjust the relation information after an edit update is performed. On windows 7 machines this behavior brings OR updates to a slooooow crawl.

How to Resolve

To fix this you can contact HP support and obtain hot-fix “QTP_00948 – Skip adjusting test object relations during renaming object repository”.

If I wasn't afraid that HP would harass me for posting it I would. To be safe, since miss-installing hotfixes can cause serious issues you need to contact HP to get your hands on this hotfix.

6 comments
nir - October 13, 2012

Its not only about repository, the entire script execution gets badly affected by the QTP11 and Windows 7 combo. It seems that QTP11 performance had issue with win7 and HP need to look around very soon instead of releasing patched for each issues separately.

Reply
    Joe Colantonio - October 13, 2012

    nir » Hi – we recently switched from running on XP machine to windows 7 machines but I have to say I have not seen any script execution performance issues yet. Are you running test from ALM11?

    Reply
mike pietsch - October 17, 2012

All the more reason to just stay away from the OR altogether and let QTP discover the objects it is acting on dynamically.

Reply
Manju - October 25, 2012

Hi,
Am facing an issue where in am unable to update the object in the OR at runtime, on a windows 7 machine. The same script works fine on windows XP.

Actually at runtime, am updating the index of the same object more than once. It works fine for the first 2 updates & then it doesn’t. [This is the pattern i noticed].

Did install the patch. However still noticing the same issue.

Please let me know if you need more info on this issue.

Hoping to get a solution to this issue.

Regards,
Manju

Reply
Manju - October 25, 2012

Hi,

Sorry, forgot to mention the following in my previous post
—————————
Operating System : Windows 7
QTP 11.
Patch : QTP_00948
———————————-
Am facing an issue where in am unable to update the object in the OR at runtime, on a windows 7 machine. The same script works fine on windows XP.

Actually at runtime, am updating the index of the same object more than once. It works fine for the first 2 updates & then it doesn’t. [This is the pattern i noticed].

Did install the patch. However still noticing the same issue.

Please let me know if you need more info on this issue.

Hoping to get a solution to this issue.

Regards,
Manju

Reply
    Joe Colantonio - November 14, 2012

    Manju » Hi Manu – I have not been able to reproduce or find a way to resolve this issue. You might want to contact HP support and see if they can help. Anyone else have any suggestions?

    Reply
Click here to add a comment

Leave a comment: