HP LeanFT Support Matrix

Automation Guild Online Conference Top ad

Does LeanFT 12.5 Support Matrix

I've already gotten a bunch of emails asking me whether a certain OS or browser is supported using LeanFT 12.5. Just like I've done in the past with previous versions of Quick Test Professional (QTP) and Unified Functional Testing (UFT) 12.5 , here is the support matrix for HP's LeanFT 12.5:

(*FYI: Because LeanFT uses the same UFT engine under the covers the same limitations that you have seen with UFT will also apply to LeanFT)

Be sure to check back often for patch updates.

Also HP has a great LeanFT Help Center site dedicated to LeanFT and pricing on their Saas site

LeanFT Supported OS



Operating System

Supported?

Server 2008 R2 SP1 (64-bit) 1

Yes

Windows 7 SP1(32-bit)

Yes

Windows 7 SP1 (64-bit)

Yes

Windows 8

Yes

Windows 8.1

Yes

Server 2012

Yes

Server 2012 R2

Yes


HP Products supported by LeanFT

*To be able to use your UFT license with LeanFT you need to upgrade your License Server to Auto Pass server. The gotcha is that the auto pass server does not have a locking-code number so you need to supply your IP address of the auto server to HP when you request new licenses or to upgrade.

Product/Standard

Version

Supported?

HP Functional Testing Concurrent License Server

1.01


11.00


Autopass 8.3

No


No


Yes

HP Application Lifecycle Management

11.52


12.00


12.01


12.20

Coming in a future release. No.

No.


Coming in a future release.


Lean FT Supported IDE


Layer

Product

Version

Supported?

IDE

Visual Studio

2010

No

2012

Yes (All editions except Express)

2013

Yes (All editions except Express)

Eclipse

Kepler (4.3)

Yes

Luna (4.4)

Yes

Testing Frameworks

NUnit

2.6.0-2.6.4

Yes

MSTest

Yes

JUnit

4.*

Yes

Java

JRE version

1.7 and later

Yes


LeanFT Supported Technologies


LeanFT is new and does not support all the technologies that UFT does. HP claims LeanFT is not a replacement for UFT so not sure how many other currently not supported technologies will make their way into LeanFT.

Browsers Supported



Layer

Product / Standard

Version

Supported?

Browsers

IE

8.00

Yes

9.00

Yes

10.00

Yes

11.00

Yes

Firefox

10, 17, 24 ESR

Yes

25.0 – 26.0

No

27.0

Yes

28.0

Yes

29.0

Yes

30.0

Yes

31, 31 ESR

Yes

32.0

Yes

33.0

Yes

34.0

Yes

35.0

Yes

36.0

Yes

37.0 & 38

Yes


Chrome

31.0

Yes

32.0

Yes

33.0

Yes

34.0

Yes

35.0

Yes

36.0

Yes

37.0

Yes

38.0

Yes

39.0

Yes

40.0

Yes

41.0

Yes

42.0

Yes

43.0

Yes

44.0

Yes

Safari on Mac

7.00

Coming in a future release.

Browser Technologies

HTML

2.00

Yes

3.20

Yes

4.00

Yes

5.00

Yes: WebRange, WebNumber, WebVideo, WebAudio

XML

1.00

Yes



.NET


Layer

Product / Standard

Version

Supported?

Microsoft .NET Framework

Microsoft .NET Framework

2.00

Yes

3.00

Yes

3.5 SP1

Yes

4.0

Yes

4.5

Yes

4.5.1

Yes

4.52

Yes

Microsoft .NET Controls

Windows Forms

All

Yes

Web Forms

All

No


WPF

Layer

Product / Standard

Version

Supported?

Windows Presentation Foundation

Windows Presentation Foundation controls

3.0

Yes

3.5

Yes

Windows Presentation Foundation

4.0

Yes

4.5

Yes

Silverlight

Silverlight

2.00

No

3.00

No

4.00

No

5.XX

No


SAP


Product / Standard

Version

Supported?

SAPUI5

SAPUI5 applications for Desktop

Yes




2 comments
Pete - April 14, 2016

LeanFT 12.5 also supports Eclipse Mars (4.5.1), though unofficially, in case anyone is wondering whether they can use LeanFT with a newer version of Eclipse.

Reply
Anirudh Garg - February 17, 2017

Hi Joe,

I have downloaded MS Visual Studio 2015 version at home and I am interested to know if LeanFT would be compatible with it or not?

I am currently using with VS 2012 premium version in office and it works perfectly fine.

Thanks,
Anirudh

Reply
Click here to add a comment

Leave a comment: