HP UFT 12.5 Support Matrix with Patch Updates

Does UFT 12.5 Support

I’ve already gotten a bunch of emails asking me whether a certain OS or browser is supported using UFT 12.5. Just like I’ve done in the past with previous versions of Quick Test Professional (QTP) and Unified Functional Testing (UFT), here is the support matrix for HP’s UFT 12.5:

Be sure to check back often for patch updates.

Operating Systems | Version Control | Browsers | Delphi | Flex | Java| .NET | WPF | Mobile | Oracle | People Soft | SAP |Siebel | Terminal Emulator | UFT API | PATCHES

UFT 12.5 Supported Operating Systems

OS

Supported?

XP SP3 (32-bit)

No

XP SP2 (64-bit)

No

2003 SP2 (32-bit) 1

No

2003 SP2 (64-bit) 1

No

2003 R2 (32 & 64 bit) 1

No

Vista SP2 (32-bit)

No

Vista SP2 (64-bit)

No

Server 2008 SP2 (32 & 64 bit) 1

No

Server 2008 R2 SP1 (64-bit) 1

Yes

Windows 7 SP1(32-bit)

Yes

Windows 7 SP1 (64-bit)

Yes

Windows 8 2

Yes

Windows 8.1 2

Yes

Server 2012 2

Yes

Server 2012 R2 2

Yes

 

UFT 12.5 Version Control supported

Product

Version

Supported?

GIT

Any

Yes

Subversion

Any

Yes

TortoiseSVN

1.7.x or earlier

No

1.8.x

Yes

 

UFT 12.5 Compatibility with Quality Center / Application Lifecycle Management

Product

Version

Supported?

QC

9.00

No

9.20

No

10.00

No

11.00

No

11.52

Yes

 

Note: Between patch 2 and patch 4 you must install the MS Redistributable 2005 to use the UFT Add-in for ALM)

12.00

Yes

12.01

Yes

12.20

Yes

ALM

11.00

No

11.50

No

11.52

Yes

 

Note: Between patch 2 and patch 4 you must install the MS Redistributable 2005 to use the UFT Add-in for ALM)

12.00

Yes

12.01

Yes

12.20

Yes

 

UFT 12.5 Browsers Supported

Browser

Version

Supported?

Internet Explorer

7.00

No

8.00

Yes

9.00

Yes

10.00

Yes

11.00

Yes

11.00 EPM

Yes (Other than ActiveX, Silverlight, Flex)

Firefox

3.60

No

5.00

No

6.00 – 15.00

No

16.000

No

17.000

No

18.000

No

19.00-

21.00

No

22.00-

24.00

No

10, 17, 24

ESR

Yes

25.0 – 26.0

No

27.0

Yes

28.0

Yes

29.0

Yes

30.0

Yes

31, 31 ESR

Yes

32.0

Yes

33.0

Yes

34.0

Yes

35.0

Yes

36.0

Yes

37.0

Yes

38, 38 ESR

Yes

39.0

Yes

Chrome

12-16

No

17.00

No

18-26

Yes (No record)

27-29

Yes (No record)

30.0

Yes (No record)

31.0

Yes

32.0

Yes

33.0

Yes

34.0

Yes

35.0

Yes

36.0

Yes

37.0

Yes

38.0

Yes

39.0

Yes

40.0

Yes

41.0

Yes

42.0

Yes

43.0

Yes

44.0

Yes

Safari on Mac

6.00

Yes

6.10

Yes

7.00

Yes

7.10

Yes

8.00

Yes

HTML

2.00

Yes

3.20

Yes

4.00

Yes

5.00

Yes: WebRange, WebNumber, WebVideo, WebAudio

XML

1.00

Yes

 

Delphi Add-in Support

Layer

Product / Standard

Version

Supported?

Delphi

Delphi IDE versions

2007.00

Yes

2009.00

Yes

2010.00

Yes

XE

Yes

XE2

Yes

XE7

Yes

Delphi controls

Win32 VCL library

Yes

CLX

No

InfoPower Controls

TwwDBEdit

InfoPower Studio 2007

InfoPower Studio 2009

InfoPower Studio 2010

Yes

TwwDBSpinEdit

Yes

TwwDBRichEdit

Yes

TwwDBGrid

Yes

 

Flex Add-in Support

Layer

Product/Standard

Version

Supported?

Flex

3.60

Yes

4.10

Yes

Flex SDK

4.5.x

Yes

Flex SDK

4.9.x

Yes

Flex SDK

4.60

Yes

Flex SDK

4.12.x

Yes

Supported Browsers

IE

All supported Versions

Yes

Safari

All Versions

No

Chrome

All Versions

No

FireFox

All Versions

No

 

Java Add-in Support

Layer

Product / Standard

Version

Supported?

Oracle SDK

1.4.0_x

No

1.4.1_x

No

1.4.2_x

No

1.5 (aka Java 5.0

Update)

Yes

1.6

Yes

1.7

Yes

1.8

Yes

Oracle Java Web Start

1.4.x

No

1.5.x

Yes

1.6.x

Yes

IBM

1.4.0_x

No

1.4.1_x

No

1.4.2_x

Yes

1.5 update x

Yes

1.6

Yes

Microsoft Internet Explorer JVM

3158.00

No

3810.00

No

Oracle Jinitiator (see oracle Add-In)

Any version

No

BEA JRockit

Any version

No

Oracle AWT (Abstract Window

Toolkit)

1.40

No

1.4.1

No

1.4.2

No

1.5

Yes

1.6

Yes

1.70

Yes

JFC (Swing)

1.0.x

No

1.1 (Swing from JDK

>1.2)

Yes

SWT Standard Widget Toolkit

3.1.2

Yes

3.2

Yes

3.3

Yes

3.4

Yes

3.5

Yes

3.6

Yes

3.7

Yes

3.8

Yes

4.20

Yes

KL Group, aka Sitraka, aka Quest

3.x

Yes (Field, BWT, & Table

Objects)

4.5 (LiveTable)

No

5.0 (LiveTable)

No

6.0 (LiveTable)

Yes

Sitraka LiveTable

4.5

Yes

5.00

Yes

6.00

Yes

UFT Java Add-in

Extensibility

Oracle SDK

1.5 (32bit only)

Yes

1.6

Yes

1.7

Yes

Eclipse

3.1.2

No

3.2

No

3.3

Yes

3.4

Yes

3.5

Yes

3.6

Yes

3.7

Yes

3.8

Yes

4.20

Yes

 

.NET Add-in Support

Layer

Product / Standard

Version

Supported?

Microsoft .NET Framework

Microsoft .NET Framework

1.00

No

1.10

No

2.00

Yes

3.00

Yes

3.5 SP1

Yes

4.0

Yes

4.5

Yes

4.5.1

Yes

4.5.2

Yes

Microsoft .NET Controls

Windows Forms

All

Yes

Web Forms

All

Yes

Third Party .Net Controls

ComponentOne TrueDB for .Net

1.2x

Yes

1.3x

Yes

2.00

Yes

ComponentOne FlexGrid for .Net

1.1x

Yes

2.00

Yes

2.50

Yes

DevExpress XtraGrid

1.50

Yes

2.00

Yes

Farpoint

Any

Yes

Infragistics UltraWinGrid

2.0x

Yes

3.2.X

Yes

Third Party .Net Web Controls

Infragistics UltraWebGrid

1.00

Yes

2.00

Yes

3.10

Yes

DevExpress ASPxGrid

1.2.0.1

Yes

UFT .Net Add-in Extensibility

Microsoft .NET Framework

1.1 (SP1+)

No

2.0

Yes

3.0

Yes

3.5

Yes

4.0

Yes

4.5

Yes

4.5.1

Yes

Visual Studio

2003

Yes

2005

Yes

2008

Yes

2010

Yes

2012

No

2013

No

 

.NET WPF Support

Layer

Product / Standard

Version

Supported?

Windows Presentation Foundation

Windows Presentation Foundation controls

3.0

Yes

Windows Presentation Foundation controls

3.5

Yes

Windows Presentation Foundation

4.0

Yes

Windows Presentation Foundation

4.50

Yes

Silverlight

Silverlight

2.00

Yes (excluding Silverlight

Runtime)

Silverlight

3.00

Yes (excluding Silverlight

Runtime)

Silverlight

4.00

Yes

Sliverlight

5.XX

Yes

UFT WPF and Silverlight Add-in

Extensibility

Silverlight version (relevant for Silverlight only)

3.00

Yes

4.00

Yes

5.XX

Yes

Microsoft .NET Framework (relevant for

WPF only)

3.00

Yes

3.50

Yes

4.00

Yes

4.50

Yes

4.5.2

Yes

Visual Studio

2005

No

2008

Yes

2010

Yes

2012

No

2013

No

 

Mobile Add-in Support

Layer

Product/Standard

Version

Supported?

Applications

Native

Yes

Hybrid

Yes

Web

No

Operation Systems

Android

4.1+

Yes

iOS

6+

Yes

Windows Phone

No

Supported Browsers

Internet Explorer

7.00

No

8.00

No

9.00

No

10.00

Yes

11.00

Yes

 

Oracle Add-in Support

Layer

Product / Standard

Version

Supported?

Web Browser

Internet Explorer

6.00

No

7.00

Yes

8.00

Yes

9.00

Yes

10.00

Yes

11.00

Yes

Java Runtime Engines

Oracle Jinitiator 4

1.1.7

No

1.1.8.x

No

1.3.1.x

Yes

Oracle Plug-In 4

1.4

No

1.5

Yes

1.6

Yes

Oracle AWT (Abstract Window Toolkit)

1.4.1.x

No

1.5.x – 1.6.x

Yes (with Java Add-in)

JFC (Swing)

1.4 – 1.6

Yes (with Java Add-in)

Development Tool

Oracle Forms (Java)

4.5

No

5.00

No

6i

Yes

9i

Yes

10g (releases 1 and 2)

Yes

11g

Yes

11gR2

Yes

Oracle Applications

E-business Suite

11.5.7

Yes

11.5.8

No

11.5.9

Yes

11.5.10

Yes

12.00

Yes

12.1

Yes

12.1.1

Yes

12.1.3

Yes

12.2.2

Yes

12.2.4

Yes

 

People Soft Add-in Support

Product/Standard

Version

Supported?

PeopleTools

8.40 – 8.43

Yes

8.46 – 8.50

Yes

8.52

Yes

8.53

Yes

Client Modules

8.00

Yes

8.30

Yes

8.40

Yes

8.80

Yes

8.90

Yes

9.00

Yes

 

SAP Add-in Support

Product / Standard

Version

Supported?

SAPGUI

6.20

Yes

6.40

No

7.10

No

7.20

Yes

7.30

Yes

7.40

Yes

Web Client (Internet Transaction Server)

6.20

No

ECATT

6.2.0

Yes

6.4.0

Yes

Solution Manager

7.1

Yes

Portals

7.00

Yes

7.30

Yes

Interactive Center WebClient (ICWC) 1.0

CRM 4.0

No

CRM 5.0

No

Interactive Center WebClient (ICWC) 2.0

CRM 2007 5

Yes

CRM 7.0

CRM 7.0

Yes

CRM 7.02 (WebCUIF 7.31)

Yes

WebDynpro ABAP

NW 7.01

Yes

NW 7.02

Yes

NW 7.4

Yes

WebDynpro Java

NW 7.3

Yes

NetWeaver Business Client for HTML

3.5

Yes

SAPUI5 applications (Including Fiori)

Up to 1.28

Yes

NWBC Desktop

4.0

Yes

 

Siebel Add-in Support

Product / Standard

Version

Supported?

Standard Interactivity (SI)

7.0.3.x

No

7.0.4.303

No

7.0.4.305

Yes

7.5.2.211

No

7.5.2.214

Yes

7.5.3

Yes

7.7 6

Yes

7.80

Yes

8.00

Yes

High Interactivity (HI)

7.0.3.x

No

7.0.4.303

No

7.0.4.305

Yes

7.5.2.211

No

7.5.2.214

Yes

7.5.3

Yes

7.70

Yes

7.80

Yes

8.00

Yes

8.1.1

Yes

8.1.1.6

Yes

8.1.1.8

Yes

8.1.1.9

Yes

8.1.1.11

Yes

8.2.2

Yes

8.2.2.4

Yes

Siebel Open UI

8.1.1.11

Yes

 

Note: Supported web browsers: IE10, IE11 , Chrome)

8.2

Yes

8.2.2.4

Yes

 

 

Terminal Emulator Add-in Support

 

Product/Standard

Version

Supported?

Attachmate Extra

2000.00

No

6.40

No

6.50

No

6.70

Yes

7.00

Yes

7.10

Yes

8.00

Yes

9.00

Yes

9.10

Yes

9.2

Yes

Attachmate Extra Terminal Viewer

3.10

Yes

Compatible with Extra 9

No

Exceed

No

Hummingbird HostExplorer

6.10

Yes (3270)

6.20

Yes (3270)

7.00

No

7.1.1

No

8.00

Yes (3270)

9.00

Yes (3270)

10.00

Yes

2007 (12)

Yes

13.00

Yes

14.00

Yes

14 (64bit)

Yes

IBM Client Access

3.20

Yes

5.10

Yes

IBM Personal Communications (PCOM)

4.10

No

4.20

No

5.00

Yes

5.60

Yes

5.70

Yes

5.80

No

5.90

Yes

6.00

Yes

IBM WebSphere Host on Demand

8.00

Yes

9.00

No

10.00

Yes

11.00

Yes

Jacada

Any

No

Jolly Giant

QWS Secure

No

QWS Plus

No

Microfocus Rumba 7

5.20

No

2000.00

No

7.00

Yes

7.1.1

Yes

7.20

Yes

7.50

Yes

8.10

Yes

8.20

Yes

Microfocus Web-to-Host 7

5.00

Yes

5.0 SP1

Yes

5.30

Yes

6.10

Yes

6.20

Yes

NetSoft Elite

3.11

No

3.12

No

Zephyr Passport PC TO HOST

2004.00

Yes

2007.00

Yes

Zephyr Passport WEB TO HOST

2004.00

Yes

2007.00

Yes

Seagull BlueZone

3.20

Yes (3270)

4.00

Yes (3270)

5.00

Yes(3270)

6.X

Yes(3270)

WRQ Reflections

6.10

No

6.20

No

7.00

No

8.00

Yes

9.00

Yes

10.00

Yes

11.00

Yes

12.00

Yes

13.00

No

14.00

Yes

2007.00

Yes (SP1+)

2014.00

Yes

AttachmateWRQ Reflection for UNIX and OpenVMS

12.00

Yes (text only)

14.00

Yes (text only)

HP TeemTalk

7.20

Yes

WRQ Reflections for the Web

Any

No

Putty

Any

Yes

 

 

UFT API Supported Technologies

 

Layer

Product/Standard

Version/Type

Supported?

Web Services

WSDL

1.10

Yes

2.00

No

SOAP

1.10

Yes

1.20

Yes

Attachments

MIME

Yes

DIME

Yes

WS-I

1.00

No

1.10

No

1.20

No

2.00

Yes

UDDI

2.x

No

3.x

Yes

WADL

Yes

Security

Web Services Security tokens

X509

Yes

UserName

Yes

Kerberos

Yes

Kerberos2

Yes

SAML

Yes

Web Services WCF Security

CustomBinding

Yes

HTTPBinding

Yes

Federation

Yes

Web Services WS – Adressing

1.00

Yes

04/08

Yes

04/03

Yes

SSL

3.00

Yes

HTTP

HTTP

1.00

Yes

1.10

Yes

Messaging Services

JMS – interfaces

1.0.2b

Yes

1.10

Yes

JMS – Servers

WebLogic Platform 8.1

Yes

ActiveMQ 5.3.0

Yes

Tibco 6.0

Yes

IBM WebSphere MQ

6.00

No

7.00

Yes

7.10

No

7.50

No

SAP

SAP .Net Connector

3.00

Yes

ECC

6.00

Yes

5.00

Yes

Solution Manager

7.01

Yes

R3

4.70

Yes

SCM

7.00

Yes

CRM

7.01

Yes

PI

7.30

Yes

Java

JVM

JRE 7 Update 5

Yes

JSON

JSON

Yes

XML technologies

XML

1.00

Yes

1.10

No

XSD

1.00

Yes

1.10

No

Xpath

1.00

Yes

2.00

No

Microsoft

.Net

4.00

Yes

Excel

2007.00

Yes

2010.00

Yes

Activity Wizard

Visual Studio

2010 and lesser

No

2012.00

Yes

2013.00

No

Web Sockets

Yes

Network Capture

HAR

Yes

tcpdump/libpcap

Yes

PATCHES

9comments
Ethel Aardvaark - November 2, 2015

This is really useful stuff. It would be even more useful if it referred back to official HP documentation, as my boss will only accept this coming from HP.

But thanks for this!

Reply
    Joe Colantonio - November 10, 2015

    Hi Ethel – I will add the reference back to the official HP doc.

    Reply
Cédric Mabileau - April 28, 2016

Hello,
I see you note UFT 12.5 as being compatible with win8. Did you try it yourself ?
I did it and something weird occured. UFT launched, the scripts worked, but every new window was not put “on top”. I had to click on uft to get the pop up on top.
This makes UFT very annoying to use. I am now looking to install UFT on another environment, and my company would like win 8, i am reluctant as i already had some mishaps, but i only tried it once.
Do you have any experience with UFT on Win 8 ?
Thanks in advance for your answer,
Cédric.

Reply
    Joe Colantonio - May 10, 2016

    I have not used on Windows 8 myself but I have not heard of any issues with it or see and KB articles on known issues with UFT 12.5 and Windows 8. What errors are you getting? Just make sure you install all the required service packs for UFT

    Reply
Dusan - August 29, 2016

Well even if I saw on youtube that somehow installation passes and everything works on youtube real story is a bit different . I have windows 10 and it’s not working properly. Can’t make it work as it should and support center is well how to say it…they never answered on a questions I made….to bad…such a nice tool for testing buy not working on windows 10

Reply
Raveendra B - September 8, 2016

UFT is working fine in Windows 8. So far we did not find any issues.

Reply
Divya - September 15, 2016

Hi Joe,
Hope you will be able to help me out .The application UI controls which i am currently working is developed using ExtJS 5 version but when i try identifying the objects in UI it shows as “WebElement” instead of “ExtJs”prefix. When i try adding in ExtJS addins in UFT 12.52 its not displaying under Web Addins ,my question is a) UFT 12.52 does it recognize the object which developed using ExtJS 5.0? b)If Yes to the question a, do i need to buy the separate addins for ExtJS because its not showing under Web Addins when i try to select Web addins in addin manager.

Reply
Sanjay - December 15, 2016

Hi, we recently upgraded from 12.51 to 12.54 and also upgraded, JAVA version from 7 to 8. And somehow, we have started seeing very high number of failures. Can someone help here? any pointers to what might have gone wrong?

Reply
Click here to add a comment

Leave a comment: