QuickTest Pro – Missing Menu Items.

Code Hacker


This drives me crazy! Occasionally I find that QTP is missing some of its menu items. I see this on different machine at different times. And I’ve seen the behavior in QTP 11 and QTP 10 – not sure what causes it. Doing a re-install “repair’ option doesn’t even fix it. But no worries — here is a quick fix. To restore all your menu items:

  • Right click on the QTP toolbar and select Customize…
  • In the Customize dialog choose the Toolbars tab
  • Under the Toolbars tab click on the ‘Restore All’ button

All your menu items should now appear.

Hope this saves someone some time.

68comments
rahul - September 9, 2011

Hi Joe,

Thanks a lot for the solution. It saved my time. Even i did the same i.e reinstall but again it was there. thanks a ton again :)

Also, i got a wiered problem yesterday that i was unable to type or click on the Test Window. didn;t get any solution even after googling it. Do you know what might be the reason and possible solution .

Thanks again .
Rahul

Reply
    Joe Colantonio - September 9, 2011

    rahul » Hi Rahul – I’m glad this helped you! This happens to one of my machines at least once a month – it use to drive me crazy. Cheers~Joe

    Reply
      Suresh Madhavarao - March 22, 2012

      hello Joe,
      thanks a lot, simple steps and Best one.
      i too reinstalled and lot of excercise i did.
      finally i got this solution from your blog

      thanks a lot
      I’m facing one more issues, when automation running, when scipts try to delete some option in my application there will be windows popup dialog like “Are you sure you want to delete” with OK and cancle button. i use to take RDC and run the script and i minimize/closed the rdc. that time this dialog goes behind the app and qtp not able to find and click on OK button. how to solve this.

      thanks
      Suresh

      Reply
        Joe Colantonio - March 27, 2012

        Suresh Madhavarao »
        Hi Suresh – before you try to click on the button do you first perform an active and a move on the dialog? For example:

        Dialog(“your dialog”).Activate
        Dialog(“your dialog”).Move 200,200.

        I also sometimes have odd issues when using RDC. That’s why i use either RealVNC or TightVNC whenever I can.

        Reply
Tinu - September 15, 2011

thank u..u saved a hell lot of time..thank u very much.

Reply
    Joe Colantonio - September 16, 2011

    Tinu » Thanks Tinu – Glad it helped you! Cheers~Joe

    Reply
malathi - December 12, 2011

Thanks a lot.
It is really a great help .
Best Wishes.

Reply
    Joe Colantonio - December 13, 2011

    malathi »This is a real annoying issue so I’m glad my quick fix worked for you!

    Reply
Claus - February 1, 2012

This fix saved my day! Working with both QTP 10 & 11, this fix is really helpfull. Keep up the good work on this site. Thank you!

Reply
    Joe Colantonio - February 1, 2012

    Claus » Awesome!

    Reply
Anandh - March 1, 2012

Its working fine.Thanks alot

Reply
    Joe Colantonio - March 2, 2012

    Anandh » Cool!

    Reply
Loshto - March 8, 2012

Thanks Joe , this is the second its been happening and i decided to google and walla!! i found a solution from this website!!

Reply
    Joe Colantonio - March 9, 2012

    Loshto » Cool – that’s what I like to hear :)

    Reply
Olga Corredor - May 15, 2012

Muchas gracias, despues de varios dias intentando repararlo he logrado solucionarlo.. Muy Muy util información.

Thank you very much.

Reply
    Joe Colantonio - May 16, 2012

    Olga Corredor » Awesome!

    Reply
Suresh Madhavarao - June 24, 2012

hello Joe,
I’m facing one issues, while automation running on RDC, there is some popup to confirm like for deleting “Are you sure want to delete” click Yes or NO and cancle button. When i close the RDC or Minimize, QTP not able to locate the OK button and error message were displayed. How to handle this, i belive i tried with activate option also, it didnt work.
please suggest a solution.

Thanks
Suresh.M

Reply
Tanka from Russia - June 26, 2012

Hi! Thanks a lot! For couple of hours I’ve been thought I am a genious-software-hacker =)

Reply
SebastianL - July 16, 2012

Thanks for the solution. It´s fast and useful. Congrats for your work.

Reply
    Joe Colantonio - July 17, 2012

    SebastianL » Thanks Sebastian!

    Reply
Naveen - July 25, 2012

Hi Joe …

Great work … keep rocking Joe
I m unlucky that i got this solution after wasting so much of time in that ….Happy that i got the solution now

Reply
reddy - September 11, 2012

Awesome, Joe.

Reply
rk - October 10, 2012

Joe,
thanks for the solution. i tried many options.. modify, repair, uninstall, clean install.. but nothing worked.. atlast found this simple way :)

Reply
    Joe Colantonio - October 11, 2012

    rk » Cool!

    Reply
Chris - November 13, 2012

Ohhh… y didn’t i think of it..!!!! In the Cutomize option tried adding all the needed menu items as command buttons as a quick fix… but that didn’t work as well… wouldn’t allow a drag drop! Thanks! Glad i didn’t try the re-install :)

Reply
monica - November 17, 2012

thank you so much. it worked. it was going crazy. i was trying to reinstall no of ties and all in vain. your solution was quick and easy. thanks again :)

Reply
    Joe Colantonio - November 19, 2012

    monica » Awesome!

    Reply
swetr - January 11, 2013

One BIG thank you. I was almost crazy from trying different unsuccessful solutions. You saved me.

Reply
    Joe Colantonio - January 16, 2013

    swetr » Awesome – thanks! Glad it helped you!!

    Reply
Chandra - January 21, 2013

Thanks Joe! This is a very quick solution for missing QTP menu items problem. Your solution resolved my issue.

Thanks again,
Chandra

Reply
    Joe Colantonio - January 21, 2013

    Chandra » Cool! Glad it helped

    Reply
Jeff - January 29, 2013

Thanks! Clever guy.

Reply
    Joe Colantonio - January 29, 2013

    Jeff » Cool – glad it helped you!

    Reply
Vinay - February 18, 2013

Thanks Joe it worked for me:)

Reply
Deepika - March 12, 2013

Thanks alot it really worked well

Reply
corey - April 1, 2013

Just saved me today. Thanks Joe!

Reply
SumaGeorge - April 4, 2013

Thanks Much Joe! You are Awesome!

Reply
    Joe Colantonio - April 4, 2013

    SumaGeorge » Thanks – glad it helped you!

    Reply
Karthik - April 5, 2013

Thanks joe!, tot QTP got crashed, because on few occasion while importing excel to datatable QTP will close due to unexpected error

Reply
Anshul - April 9, 2013

Thank You so much… You saved me a lot of time…

Reply
Terence - May 1, 2013

Thank you – This was driving me crazy for a while!

Reply
Pavan Acharya - May 21, 2013

Thanks a lot. This was driving me crazy. Your solutions really work !

Reply
Aravindhan - May 24, 2013

Hi Joe

I tried with the solution given by you. i.e., to restore the toolbar. But it didn’t work for me. Still facing the same issue. Any other solutions?

Reply
Karun - June 19, 2013

Thanks for the solution.

Reply
Ondrej - July 12, 2013

Joe, i was about to reinstall qtp and realized i somewhere lost my license keys, so… I am very happy now, thanks!!

Reply
Ananth - August 13, 2013

Thanks a lot. I was in the middle of work and this thing made me to reinstall the software…
Your solution helped me a lot

Reply
Deepti - August 28, 2013

Thanks a Ton Joe ! Keep up the good work.
Many thanks again,
Deepti

Reply
saju ta - September 13, 2013

Great Solution!!!!!!!

Reply
vishwani - September 25, 2013

Thanks a Lot!!!!! It saved my time…I appriciate it…

Reply
chinna krishna reddy - October 3, 2013

i tried so many ways but but i didn’t solution
but this video is very usefull, thanks a lot

Reply
Ayelet - October 23, 2013

Hi,

Thank you very much! it was very helpful video!

Ayelet

Reply
    Joe Colantonio - October 23, 2013

    Cool – glad it helped!

    Reply
Raviteja - November 11, 2013

Hi Joe,

I came to know that the Quality center supports version control by having a third party plug in. But the problem was that the plug in saves the previous version in qc database. May i know that can we make that plug in save the changes(versions) in my local system instead of the qc database.

Thanks in advance.

Regards,
Ravi

Reply
    Joe Colantonio - November 13, 2013

    What version of QC are you using – the newer versions only have built in version control.

    Reply
Pratik - December 26, 2013

Wonderful Solution and it saved lot of time

Reply
GIRISH - February 4, 2014

Hi Joe,

I reinstalled UFT but the problem persisted, your solution saved a lot of time, thanks a lot.

Any idea why this happens? it happened to me after installing PDF Test Toolkit and i thought that was the main culprit.

But after going through your page realized issue is with UFT.

Thanks,
Girish

Reply
    Joe Colantonio - February 4, 2014

    Hi Girish – Unfortunately I have not been able to track this behavior down to a single cause.

    Reply
Benak - June 2, 2014

Hi Joe,

Thanks a lot for the solution.

Regards,
Benak

Reply
Paul Grossman - August 25, 2014

Hey Joe,

This one hit me this AM, again. I really wish they would resolve this thing. Particularly as I have the wrong button, “Restore Layout”, memororized as the solution. Thanks to you and Google it was a quick fix.

Reply
    Joe Colantonio - August 26, 2014

    HI Paul – I agree not sure why this has not been resolved by HP yet.

    Reply
srinivas - November 5, 2014

Nice tip and it worked magically

Reply
Mike L - January 5, 2015

I have tried this and it does not work for me. The Menu Bar goes away if you open a script or start a new one. It does appear when you first go into QTP’s “Start Page”.

Reply
Nitesh - March 26, 2015

When we open HP QTP 11 then menu bar is shown. But if we take “new test” then menu bar is not shown. I tried these steps: Right-click on status bar-> then go to ” customized”-> then go to ” toolbar”-> But then there is “Menu Bar” is option/check-box is not clicked/ is not select. Then please give me the solution for select the check-box of Menu bar. why menu bar is not selected by me. Kindly request to you give me the solution quickly for shown Menu Bar when we open new test.

Reply
James - March 31, 2015

Thank you very much, a problem I have seen a number of times, hadn’t realised how simple the fix was!

Reply
M Adnan - June 2, 2015

Great Help… Thanx

Reply
Sankar K. - May 8, 2016

Great. It’s working now. Thanks a lot…

Reply
Click here to add a comment

Leave a comment: